S416, 147 Pirie Street, Adelaide SA 5000 1800 818 875 [email protected]

Required Specification

You are here:
Estimated reading time: < 1 min

Technical requirements to run Jam Cyber – Cyber Security Packages

Please ensure your computer has the following technical requirements:

  • PC
    • Must be running the latest Windows version fully patched (second latest version of Windows also accepted)
  • MAC
    • Must be running the latest iteration of MAC OS fully patched (second latest version also accepted)

If your computer is not running one of these versions, or if you are not sure if your Operating System is fully patched, please discuss with our Jam Cyber Technical Support Crew.

Was this article helpful?
Dislike 0
Views: 16